Skip to main content
← All vulnerabilities
CVE-2011-4297GHSA-62WV-866C-RH86

comment/lib.php in Moodle 2.0.x before 2.0.4 and 2.1.x before 2.1.1 does not properly restrict comment capabilities, which allows remote att

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.0.4, 2.1.1
None on Exploit-DB, Metasploit or GitHub

Summary

comment/lib.php in Moodle 2.0.x before 2.0.4 and 2.1.x before 2.1.1 does not properly restrict comment capabilities, which allows remote attackers to post a comment by leveraging the guest role and operating on a front-page activity.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • moodle/moodlePackagist

    From 2.0.0 · fixed in 2.0.4

  • moodle/moodlePackagist

    From 2.1.0 · fixed in 2.1.1

References 3

openwall.com

git.moodle.org

moodle.org