Skip to main content
← All vulnerabilities
CVE-2011-4281GHSA-M97F-X4MR-4X3Q

Multiple cross-site request forgery (CSRF) vulnerabilities in Moodle 2.0.x before 2.0.2 allow remote attackers to hijack the authentication

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.0.2
None on Exploit-DB, Metasploit or GitHub

Summary

Multiple cross-site request forgery (CSRF) vulnerabilities in Moodle 2.0.x before 2.0.2 allow remote attackers to hijack the authentication of arbitrary users for requests that mark the completion of (1) an activity or (2) a course.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • moodle/moodlePackagist

    From 2.0.0 · fixed in 2.0.2

References 3

openwall.com

moodle.org

git.moodle.org