Skip to main content
← All vulnerabilities
CVE-2011-4278GHSA-6656-6QWX-4C2M

Cross-site scripting (XSS) vulnerability in the tag autocomplete functionality in Moodle 1.9.x before 1.9.11 and 2.0.x before 2.0.2 allows r

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 1.9.11, 2.0.2
None on Exploit-DB, Metasploit or GitHub

Summary

Cross-site scripting (XSS) vulnerability in the tag autocomplete functionality in Moodle 1.9.x before 1.9.11 and 2.0.x before 2.0.2 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • moodle/moodlePackagist

    fixed in 1.9.11

  • moodle/moodlePackagist

    From 2.0 · fixed in 2.0.2

References 3

openwall.com

moodle.org

git.moodle.org