Skip to main content
← All vulnerabilities
CVE-2011-4103GHSA-PVHP-V9QP-XF5RPYSEC-2014-24

emitters.py in Django Piston before 0.2.3 and 0.2.x before 0.2.2.1 does not properly deserialize YAML data, which allows remote attackers to

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 0.2.2.1, 0.2.3
None on Exploit-DB, Metasploit or GitHub

Summary

emitters.py in Django Piston before 0.2.3 and 0.2.x before 0.2.2.1 does not properly deserialize YAML data, which allows remote attackers to execute arbitrary Python code via vectors related to the yaml.load method.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • django-pistonPyPI

    From 0.2.0 · fixed in 0.2.2.1

  • django-pistonPyPI

    fixed in 0.2.3

References 5

bugzilla.redhat.com

bitbucket.org

debian.org

djangoproject.com

openwall.com