Skip to main content
← All vulnerabilities
CVE-2011-3871GHSA-MPMX-GM5V-Q789

Puppet 2.7.x before 2.7.5, 2.6.x before 2.6.11, and 0.25.x, when running in --edit mode, uses a predictable file name, which allows local us

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.7.5, 2.6.11
None on Exploit-DB, Metasploit or GitHub

Summary

Puppet 2.7.x before 2.7.5, 2.6.x before 2.6.11, and 0.25.x, when running in --edit mode, uses a predictable file name, which allows local users to run arbitrary Puppet code or trick a user into editing arbitrary files.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • puppetRubyGems

    From 2.7.0 · fixed in 2.7.5

  • puppetRubyGems

    fixed in 2.6.11

References 9

lists.fedoraproject.org

debian.org

secunia.com

puppet.com

groups.google.com

ubuntu.com