Skip to main content
← All vulnerabilities
CVE-2011-3870GHSA-QH3G-27JF-3J54

Puppet 2.7.x before 2.7.5, 2.6.x before 2.6.11, and 0.25.x allows local users to modify the permissions of arbitrary files via a symlink att

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.7.5, 2.6.11
None on Exploit-DB, Metasploit or GitHub

Summary

Puppet 2.7.x before 2.7.5, 2.6.x before 2.6.11, and 0.25.x allows local users to modify the permissions of arbitrary files via a symlink attack on the SSH authorized_keys file.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • puppetRubyGems

    From 2.7.0 · fixed in 2.7.5

  • puppetRubyGems

    fixed in 2.6.11

References 9

lists.fedoraproject.org

puppet.com

debian.org

secunia.com

groups.google.com

ubuntu.com