Skip to main content
← All vulnerabilities
CVE-2011-3587PYSEC-2026-1067GHSA-8W48-M6HX-RJW2

Unspecified vulnerability in Zope 2.12.x and 2.13.x, as used in Plone 4.0.x through 4.0.9, 4.1, and 4.2 through 4.2a2, allows remote attacke

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.12.20, 2.13.10
1 on Exploit-DB, 1 Metasploit module

Summary

Unspecified vulnerability in Zope 2.12.x and 2.13.x, as used in Plone 4.0.x through 4.0.9, 4.1, and 4.2 through 4.2a2, allows remote attackers to execute arbitrary commands via vectors related to the p_ class in OFS/misc_.py and the use of Python modules.

Timeline

  1. CVE published
  2. Public exploit on Exploit-DB

    EDB-18262

  3. Record last updated
  4. EPSS reached 10%

    FIRST estimates at least a 10% chance of exploitation in the next 30 days

Affected versions

  • n/a n/a

    Version range not reported

  • zope2PyPI

    From 2.12.0 · fixed in 2.12.20; From 2.13.0 · fixed in 2.13.10

  • zope2PyPI

    From 2.12.0 · fixed in 2.12.20

  • zope2PyPI

    From 2.13.0 · fixed in 2.13.10

References 10

bugzilla.redhat.com

secunia.com

pypi.python.org

plone.org

zope2.zope.org

Exploit-DB

GitHub · rapid7/metasploit-framework