Skip to main content
← All vulnerabilities
CVE-2011-2931GHSA-V5JG-558J-Q67C

Cross-site scripting (XSS) vulnerability in the strip_tags helper in actionpack/lib/action_controller/vendor/html-scanner/html/node.rb in Ru

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.3.13, 3.0.10
None on Exploit-DB, Metasploit or GitHub

Summary

Cross-site scripting (XSS) vulnerability in the strip_tags helper in actionpack/lib/action_controller/vendor/html-scanner/html/node.rb in Ruby on Rails before 2.3.13, 3.0.x before 3.0.10, and 3.1.x before 3.1.0.rc5 allows remote attackers to inject arbitrary web script or HTML via a tag with an invalid name.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • actionpackRubyGems

    From 2.0.0 · fixed in 2.3.13

  • actionpackRubyGems

    From 3.0.0 · fixed in 3.0.10

References 15

groups.google.com

openwall.com

lists.fedoraproject.org

bugzilla.redhat.com

debian.org

secunia.com

GitHub · rails/rails

weblog.rubyonrails.org