Skip to main content
← All vulnerabilities
CVE-2011-2197GHSA-V9V4-7JP6-8C73

The cross-site scripting (XSS) prevention feature in Ruby on Rails 2.x before 2.3.12, 3.0.x before 3.0.8, and 3.1.x before 3.1.0.rc2 does no

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.3.12, 3.0.8
None on Exploit-DB, Metasploit or GitHub

Summary

The cross-site scripting (XSS) prevention feature in Ruby on Rails 2.x before 2.3.12, 3.0.x before 3.0.8, and 3.1.x before 3.1.0.rc2 does not properly handle mutation of safe buffers, which makes it easier for remote attackers to conduct XSS attacks via crafted strings to an application that uses a problematic string method, as demonstrated by the sub method.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • actionpackRubyGems

    From 2.0.0 · fixed in 2.3.12

  • actionpackRubyGems

    From 3.0.0 · fixed in 3.0.8

  • activesupportRubyGems

    From 2.0.0 · fixed in 2.3.12

  • activesupportRubyGems

    From 3.0.0 · fixed in 3.0.8

References 7

groups.google.com

lists.fedoraproject.org

weblog.rubyonrails.org

secunia.com

openwall.com