Skip to main content
← All vulnerabilities
CVE-2011-10026GHSA-X485-RHG3-CQR4

Spreecommerce < 0.50.x API RCE

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 0.50.0
1 Metasploit module
  • Exploitation: poc
  • Automatable: yes
  • Technical impact: total

Summary

Spreecommerce versions prior to 0.50.x contain a remote command execution vulnerability in the API's search functionality. Improper input sanitation allows attackers to inject arbitrary shell commands via the search[instance_eval] parameter, which is dynamically invoked using Ruby’s send method. This flaw enables unauthenticated attackers to execute commands on the server.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: poc · Automatable: yes · Technical impact: total

  3. Record last updated

Affected versions

  • Spreecommerce Spreecommerce

    All versions

  • spreeRubyGems

    From 0.30.0.beta1 · fixed in 0.50.0

  • rd_searchlogicRubyGems

    through 3.0.1

References 6

raw.githubusercontent.com

Exploit-DB

web.archive.org

github.com

vulncheck.com

GitHub · rapid7/metasploit-framework