Skip to main content
← All vulnerabilities
CVE-2011-0696PYSEC-2011-10GHSA-5J2H-H5HG-3WF8PYSEC-2011-30

Django 1.1.x before 1.1.4 and 1.2.x before 1.2.5 does not properly validate HTTP requests that contain an X-Requested-With header, which mak

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 1.1.4, 1.2.5
None on Exploit-DB, Metasploit or GitHub

Summary

Django 1.1.x before 1.1.4 and 1.2.x before 1.2.5 does not properly validate HTTP requests that contain an X-Requested-With header, which makes it easier for remote attackers to conduct cross-site request forgery (CSRF) attacks via forged AJAX requests that leverage a "combination of browser plugins and redirects," a related issue to CVE-2011-0447.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • djangoPyPI

    From 1.1 · fixed in 1.1.4; From 1.2 · fixed in 1.2.5

  • djangoPyPI

    From 1.1 · fixed in 1.1.4

  • djangoPyPI

    From 1.2 · fixed in 1.2.5

References 18

secunia.com

vupen.com

openwall.com

bugzilla.redhat.com

lists.fedoraproject.org

ubuntu.com

securityfocus.com

mandriva.com

debian.org

djangoproject.com