Skip to main content
← All vulnerabilities
CVE-2011-0448GHSA-JMM9-2P29-VH2W

Ruby on Rails 3.0.x before 3.0.4 does not ensure that arguments to the limit function specify integer values, which makes it easier for remo

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 3.0.4
None on Exploit-DB, Metasploit or GitHub

Summary

Ruby on Rails 3.0.x before 3.0.4 does not ensure that arguments to the limit function specify integer values, which makes it easier for remote attackers to conduct SQL injection attacks via a non-numeric argument.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • activerecordRubyGems

    From 3.0.0 · fixed in 3.0.4

References 7

groups.google.com

weblog.rubyonrails.org

securitytracker.com

lists.fedoraproject.org

secunia.com

vupen.com

GitHub · rails/rails