CVE-2011-0446GHSA-75W6-P6MG-VH8J
Multiple cross-site scripting (XSS) vulnerabilities in the mail_to helper in Ruby on Rails before 2.3.11, and 3.x before 3.0.4, when javascr
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 2.3.11, 3.0.4
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
Multiple cross-site scripting (XSS) vulnerabilities in the mail_to helper in Ruby on Rails before 2.3.11, and 3.x before 3.0.4, when javascript encoding is used, allow remote attackers to inject arbitrary web script or HTML via a crafted (1) name or (2) email value.
Timeline
- CVE published
- Record last updated
Affected versions
- n/a n/a
Version range not reported
- actionpackRubyGems
fixed in 2.3.11
- actionpackRubyGems
From 3.0.0 · fixed in 3.0.4
- actionviewRubyGems
fixed in 2.3.11
- actionviewRubyGems
From 3.0.0 · fixed in 3.0.4