Skip to main content
← All vulnerabilities
CVE-2010-4340GHSA-W3J6-8J34-Q43XPYSEC-2011-24

libcloud before 0.4.1 does not verify SSL certificates for HTTPS connections, which allows remote attackers to spoof certificates and bypass

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 0.4.0, 0.4.2
None on Exploit-DB, Metasploit or GitHub

Summary

libcloud before 0.4.1 does not verify SSL certificates for HTTPS connections, which allows remote attackers to spoof certificates and bypass intended access restrictions via a man-in-the-middle (MITM) attack.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • apache-libcloudPyPI

    fixed in 0.4.0

  • apache-libcloudPyPI

    fixed in 0.4.2

References 5

mail-archives.apache.org

wiki.apache.org

bugs.debian.org

issues.apache.org