Skip to main content
← All vulnerabilities
CVE-2010-3700GHSA-3295-H9QX-R82X

VMware SpringSource Spring Security 2.x before 2.0.6 and 3.x before 3.0.4, and Acegi Security 1.0.0 through 1.0.7, as used in IBM WebSphere

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.0.6, 3.0.4
None on Exploit-DB, Metasploit or GitHub

Summary

VMware SpringSource Spring Security 2.x before 2.0.6 and 3.x before 3.0.4, and Acegi Security 1.0.0 through 1.0.7, as used in IBM WebSphere Application Server (WAS) 6.1 and 7.0, allows remote attackers to bypass security constraints via a path parameter.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • org.springframework.security:spring-security-coreMaven

    From 2.0.0 · fixed in 2.0.6

  • org.springframework.security:spring-security-coreMaven

    From 3.0.0 · fixed in 3.0.4

  • org.acegisecurity:acegi-securityMaven

    From 1.0.0 · through 1.0.7

References 6

securityfocus.com

secunia.com

issues.apache.org

springsource.com

osvdb.org