Skip to main content
← All vulnerabilities
CVE-2010-3313GHSA-5GX6-F2QQ-475F

phpgwapi/js/fckeditor/editor/dialog/fck_spellerpages/spellerpages/serverscripts/spellchecker.php in EGroupware 1.4.001+.002; 1.6.001+.002 an

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 1.6.003, 9.1.20100309, 9.2.20100309
1 on Exploit-DB

Summary

phpgwapi/js/fckeditor/editor/dialog/fck_spellerpages/spellerpages/serverscripts/spellchecker.php in EGroupware 1.4.001+.002; 1.6.001+.002 and possibly other versions before 1.6.003; and EPL 9.1 before 9.1.20100309 and 9.2 before 9.2.20100309; allows remote attackers to execute arbitrary commands via shell metacharacters in the (1) aspell_path or (2) spellchecker_lang parameters.

Timeline

  1. Public exploit on Exploit-DB

    EDB-11777

  2. CVE published
  3. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • egroupware/egroupwarePackagist

    fixed in 1.6.003

  • egroupware/egroupwarePackagist

    From 9.1 · fixed in 9.1.20100309

  • egroupware/egroupwarePackagist

    From 9.2 · fixed in 9.2.20100309

References 5

Exploit-DB

egroupware.org

debian.org

openwall.com