Skip to main content
← All vulnerabilities
CVE-2010-2487PYSEC-2010-16GHSA-5M2M-27CG-7V4V

Multiple cross-site scripting (XSS) vulnerabilities in MoinMoin 1.7.3 and earlier, 1.8.x before 1.8.8, and 1.9.x before 1.9.3 allow remote a

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 1.8.8, 1.9.3
None on Exploit-DB, Metasploit or GitHub

Summary

Multiple cross-site scripting (XSS) vulnerabilities in MoinMoin 1.7.3 and earlier, 1.8.x before 1.8.8, and 1.9.x before 1.9.3 allow remote attackers to inject arbitrary web script or HTML via crafted content, related to (1) Page.py, (2) PageEditor.py, (3) PageGraphicalEditor.py, (4) action/CopyPage.py, (5) action/Load.py, (6) action/RenamePage.py, (7) action/backup.py, (8) action/login.py, (9) action/newaccount.py, and (10) action/recoverpass.py.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • moinPyPI

    From 1.8 · fixed in 1.8.8; From 1.9 · fixed in 1.9.3

  • moinPyPI

    through 1.7.3

  • moinPyPI

    From 1.8.0 · fixed in 1.8.8

  • moinPyPI

    From 1.9.0 · fixed in 1.9.3

References 17

hg.moinmo.in

vupen.com

moinmo.in

securityfocus.com

debian.org

bugs.debian.org

marc.info

secunia.com