Skip to main content
← All vulnerabilities
CVE-2010-1619GHSA-HHXF-W8HJ-43W6

Cross-site scripting (XSS) vulnerability in the fix_non_standard_entities function in the KSES HTML text cleaning library (weblib.php), as u

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 1.8.12, 1.9.8
None on Exploit-DB, Metasploit or GitHub

Summary

Cross-site scripting (XSS) vulnerability in the fix_non_standard_entities function in the KSES HTML text cleaning library (weblib.php), as used in Moodle 1.8.x before 1.8.12 and 1.9.x before 1.9.8, allows remote attackers to inject arbitrary web script or HTML via crafted HTML entities.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • moodle/moodlePackagist

    From 1.8.0 · fixed in 1.8.12

  • moodle/moodlePackagist

    From 1.9.0 · fixed in 1.9.8

References 3

vupen.com

moodle.org

lists.opensuse.org