Skip to main content
← All vulnerabilities
CVE-2010-1618GHSA-45CH-HXGR-VX8J

Cross-site scripting (XSS) vulnerability in the phpCAS client library before 1.1.0, as used in Moodle 1.8.x before 1.8.12 and 1.9.x before 1

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 1.1.0, 1.8.12, 1.9.8
None on Exploit-DB, Metasploit or GitHub

Summary

Cross-site scripting (XSS) vulnerability in the phpCAS client library before 1.1.0, as used in Moodle 1.8.x before 1.8.12 and 1.9.x before 1.9.8, allows remote attackers to inject arbitrary web script or HTML via a crafted URL, which is not properly handled in an error message.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • apereo/phpcasPackagist

    fixed in 1.1.0

  • moodle/moodlePackagist

    From 1.8.0 · fixed in 1.8.12

  • moodle/moodlePackagist

    From 1.9.0 · fixed in 1.9.8

References 5

ja-sig.org

vupen.com

moodle.org

lists.opensuse.org