Skip to main content
← All vulnerabilities
CVE-2010-1617GHSA-Q53J-C866-H9MW

user/view.php in Moodle 1.8.x before 1.8.12 and 1.9.x before 1.9.8 does not properly check a role, which allows remote authenticated users t

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 1.8.12, 1.9.8
None on Exploit-DB, Metasploit or GitHub

Summary

user/view.php in Moodle 1.8.x before 1.8.12 and 1.9.x before 1.9.8 does not properly check a role, which allows remote authenticated users to obtain the full names of other users via the course profile page.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • moodle/moodlePackagist

    From 1.8.0 · fixed in 1.8.12

  • moodle/moodlePackagist

    From 1.9.0 · fixed in 1.9.8

References 4

cvs.moodle.org

vupen.com

moodle.org

lists.opensuse.org