Skip to main content
← All vulnerabilities
CVE-2010-1614GHSA-5FGV-CVR8-XG48

Multiple cross-site scripting (XSS) vulnerabilities in Moodle 1.8.x before 1.8.12 and 1.9.x before 1.9.8 allow remote attackers to inject ar

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 1.8.12, 1.9.8
None on Exploit-DB, Metasploit or GitHub

Summary

Multiple cross-site scripting (XSS) vulnerabilities in Moodle 1.8.x before 1.8.12 and 1.9.x before 1.9.8 allow remote attackers to inject arbitrary web script or HTML via vectors related to (1) the Login-As feature or (2) when the global search feature is enabled, unspecified global search forms in the Global Search Engine. NOTE: vector 1 might be resultant from a cross-site request forgery (CSRF) vulnerability.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • moodle/moodlePackagist

    From 1.8.0 · fixed in 1.8.12

  • moodle/moodlePackagist

    From 1.9.0 · fixed in 1.9.8

References 3

vupen.com

moodle.org

lists.opensuse.org