Skip to main content
← All vulnerabilities
CVE-2010-1104GHSA-V7Q8-WVVH-C97PPYSEC-2026-765

Cross-site scripting (XSS) vulnerability in Zope 2.8.x before 2.8.12, 2.9.x before 2.9.12, 2.10.x before 2.10.11, 2.11.x before 2.11.6, and

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.8.12, 2.9.12, 2.10.11, 2.11.6, 2.12.3
None on Exploit-DB, Metasploit or GitHub

Summary

Cross-site scripting (XSS) vulnerability in Zope 2.8.x before 2.8.12, 2.9.x before 2.9.12, 2.10.x before 2.10.11, 2.11.x before 2.11.6, and 2.12.x before 2.12.3 allows remote attackers to inject arbitrary web script or HTML via vectors related to error messages.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • zope2PyPI

    From 2.8.0 · fixed in 2.8.12

  • zope2PyPI

    From 2.9.0 · fixed in 2.9.12

  • zope2PyPI

    From 2.10.0 · fixed in 2.10.11

  • zope2PyPI

    From 2.11.0 · fixed in 2.11.6

  • zope2PyPI

    From 2.12.0 · fixed in 2.12.3

  • zope2PyPI

    From 2.8.0 · fixed in 2.8.12; From 2.9.0 · fixed in 2.9.12; From 2.10.0 · fixed in 2.10.11; From 2.11.0 · fixed in 2.11.6; From 2.12.0 · fixed in 2.12.3

References 6

vupen.com

securityfocus.com

osvdb.org

exchange.xforce.ibmcloud.com

mail.zope.org

secunia.com