CVE-2009-3009GHSA-8QRH-H9M2-5FVF
Cross-site scripting (XSS) vulnerability in Ruby on Rails 2.x before 2.2.3, and 2.3.x before 2.3.4, allows remote attackers to inject arbitr
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 2.2.3, 2.3.4
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
Cross-site scripting (XSS) vulnerability in Ruby on Rails 2.x before 2.2.3, and 2.3.x before 2.3.4, allows remote attackers to inject arbitrary web script or HTML by placing malformed Unicode strings into a form helper.
Timeline
- CVE published
- Record last updated
Affected versions
- n/a n/a
Version range not reported
- actionpackRubyGems
From 2.0.0 · fixed in 2.2.3
- actionpackRubyGems
From 2.3.0 · fixed in 2.3.4
- activesupportRubyGems
From 2.0.0 · fixed in 2.2.3
- activesupportRubyGems
From 2.3.0 · fixed in 2.3.4