CVE-2009-2940PYSEC-2009-18GHSA-XV6X-43GQ-4HFJ
The pygresql module 3.8.1 and 4.0 for Python does not properly support the PQescapeStringConn function, which might allow remote attackers t
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 4.1
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
The pygresql module 3.8.1 and 4.0 for Python does not properly support the PQescapeStringConn function, which might allow remote attackers to leverage escaping issues involving multibyte character encodings.
Timeline
- CVE published
- Record last updated
Affected versions
- n/a n/a
Version range not reported
- pygresqlPyPI
From 3.8.1 · through 4.0
- pygresqlPyPI
through 3.8.1
- pygresqlPyPI
From 4.0 · fixed in 4.1