Skip to main content
← All vulnerabilities
CVE-2009-0580GHSA-W227-XCFX-3PJ8

Apache Tomcat 4.1.0 through 4.1.39, 5.5.0 through 5.5.27, and 6.0.0 through 6.0.18, when FORM authentication is used, allows remote attacker

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 4.1.40, 5.5.28, 6.0.19
1 on Exploit-DB, 1 Metasploit module

Summary

Apache Tomcat 4.1.0 through 4.1.39, 5.5.0 through 5.5.27, and 6.0.0 through 6.0.18, when FORM authentication is used, allows remote attackers to enumerate valid usernames via requests to /j_security_check with malformed URL encoding of passwords, related to improper error checking in the (1) MemoryRealm, (2) DataSourceRealm, and (3) JDBCRealm authentication realms, as demonstrated by a % (percent) value for the j_password parameter.

Timeline

  1. Public exploit on Exploit-DB

    EDB-33023

  2. CVE published
  3. Record last updated
  4. EPSS reached 10%

    FIRST estimates at least a 10% chance of exploitation in the next 30 days

Affected versions

  • n/a n/a

    Version range not reported

  • org.apache.tomcat:tomcatMaven

    From 4.1.0 · fixed in 4.1.40

  • org.apache.tomcat:tomcatMaven

    From 5.0.0 · fixed in 5.5.28

  • org.apache.tomcat:tomcatMaven

    From 6.0.0 · fixed in 6.0.19

References 26

oval.cisecurity.org

tomcat.apache.org

marc.info

secunia.com

mandriva.com

redhat.com

debian.org

securityfocus.com

vupen.com

vmware.com

svn.apache.org

lists.apple.com

Exploit-DB

GitHub · rapid7/metasploit-framework