Skip to main content
← All vulnerabilities
CVE-2008-2938GHSA-M7XJ-CCQC-P4G2

Directory traversal vulnerability in Apache Tomcat 4.1.0 through 4.1.37, 5.5.0 through 5.5.26, and 6.0.0 through 6.0.16, when allowLinking a

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 4.1.39, 5.5.27, 6.0.18
2 on Exploit-DB, 2 Metasploit modules, 1 proof of concept on GitHub

Summary

Directory traversal vulnerability in Apache Tomcat 4.1.0 through 4.1.37, 5.5.0 through 5.5.26, and 6.0.0 through 6.0.16, when allowLinking and UTF-8 are enabled, allows remote attackers to read arbitrary files via encoded directory traversal sequences in the URI, a different vulnerability than CVE-2008-2370. NOTE: versions earlier than 6.0.18 were reported affected, but the vendor advisory lists 6.0.16 as the last affected version.

Timeline

  1. Public exploit on Exploit-DB

    EDB-6229, EDB-14489

  2. CVE published
  3. Record last updated
  4. EPSS reached 10%

    FIRST estimates at least a 10% chance of exploitation in the next 30 days

Affected versions

  • n/a n/a

    Version range not reported

  • org.apache.tomcat:tomcatMaven

    From 4.1.0 · fixed in 4.1.39

  • org.apache.tomcat:tomcatMaven

    From 5.5.0 · fixed in 5.5.27

  • org.apache.tomcat:tomcatMaven

    From 6.0.0 · fixed in 6.0.18

References 29

tomcat.apache.org

secunia.com

redhat.com

vupen.com

securityfocus.com

kb.cert.org

exchange.xforce.ibmcloud.com

lists.opensuse.org

oval.cisecurity.org

securitytracker.com

mandriva.com

support.avaya.com

Exploit-DB

GitHub · rapid7/metasploit-framework

GitHub · Naramsim/Offensive