Skip to main content
← All vulnerabilities
CVE-2008-1947GHSA-F98P-9PP6-7Q6C

Cross-site scripting (XSS) vulnerability in Apache Tomcat 5.5.9 through 5.5.26 and 6.0.0 through 6.0.16 allows remote attackers to inject ar

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 5.5.27, 6.0.18
None on Exploit-DB, Metasploit or GitHub

Summary

Cross-site scripting (XSS) vulnerability in Apache Tomcat 5.5.9 through 5.5.26 and 6.0.0 through 6.0.16 allows remote attackers to inject arbitrary web script or HTML via the name parameter (aka the hostname attribute) to host-manager/html/add.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • org.apache.tomcat:tomcatMaven

    From 5.5.9 · fixed in 5.5.27

  • org.apache.tomcat:tomcatMaven

    From 6.0.0 · fixed in 6.0.18

  • org.apache.tomcat.embed:tomcat-embed-coreMaven

    From 5.5.9 · fixed in 5.5.27

  • org.apache.tomcat.embed:tomcat-embed-coreMaven

    From 6.0.0 · fixed in 6.0.18

References 25

securityfocus.com

secunia.com

redhat.com

marc.info

oval.cisecurity.org

vupen.com

exchange.xforce.ibmcloud.com

vmware.com

mandriva.com

support.avaya.com