CVE-2007-1355GHSA-4C6X-GFC8-C26R
Multiple cross-site scripting (XSS) vulnerabilities in the appdev/sample/web/hello.jsp example application in Tomcat 4.0.0 through 4.0.6, 4.
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 4.1.37, 5.5.24, 6.0.11
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- 1 on Exploit-DB
Summary
Multiple cross-site scripting (XSS) vulnerabilities in the appdev/sample/web/hello.jsp example application in Tomcat 4.0.0 through 4.0.6, 4.1.0 through 4.1.36, 5.0.0 through 5.0.30, 5.5.0 through 5.5.23, and 6.0.0 through 6.0.10 allow remote attackers to inject arbitrary web script or HTML via the test parameter and unspecified vectors.
Timeline
- Public exploit on Exploit-DB
EDB-30052
- CVE published
- Record last updated
- EPSS reached 10%
FIRST estimates at least a 10% chance of exploitation in the next 30 days
Affected versions
- n/a n/a
Version range not reported
- org.apache.tomcat:jsp-apiMaven
From 4.1.0 · fixed in 4.1.37
- org.apache.tomcat:jsp-apiMaven
From 5.5.0 · fixed in 5.5.24
- org.apache.tomcat:jsp-apiMaven
From 6.0.0 · fixed in 6.0.11
- org.apache.tomcat:jsp-apiMaven
From 5.0.0 · through 5.0.30
- org.apache.tomcat:jsp-apiMaven
From 4.0.0 · through 4.0.6
- org.apache.tomcat:servlet-apiMaven
From 4.1.0 · fixed in 4.1.37
- org.apache.tomcat:servlet-apiMaven
From 5.5.0 · fixed in 5.5.24
- org.apache.tomcat:servlet-apiMaven
From 6.0.0 · fixed in 6.0.11
- org.apache.tomcat:servlet-apiMaven
From 5.0.0 · through 5.0.30
- org.apache.tomcat:servlet-apiMaven
From 4.0.0 · through 4.0.6