CVE-2006-6969GHSA-JG2X-R643-W2CH
Jetty before 4.2.27, 5.1 before 5.1.12, 6.0 before 6.0.2, and 6.1 before 6.1.0pre3 generates predictable session identifiers using java.util
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 4.2.27, 5.1.12, 6.0.2, 6.1.0pre3
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
Jetty before 4.2.27, 5.1 before 5.1.12, 6.0 before 6.0.2, and 6.1 before 6.1.0pre3 generates predictable session identifiers using java.util.random, which makes it easier for remote attackers to guess a session identifier through brute force attacks, bypass authentication requirements, and possibly conduct cross-site request forgery attacks.
Timeline
- CVE published
- Record last updated
Affected versions
- n/a n/a
Version range not reported
- org.eclipse.jetty:jetty-serverMaven
fixed in 4.2.27
- org.eclipse.jetty:jetty-serverMaven
From 5.1.0 · fixed in 5.1.12
- org.eclipse.jetty:jetty-serverMaven
From 6.0.0 · fixed in 6.0.2
- org.eclipse.jetty:jetty-serverMaven
From 6.1.0pre1 · fixed in 6.1.0pre3